Having Trouble with bippLang

Hello,

This is Alex. I’ve been working with Jeremy and Vishal to review the Bling language and test it out.

I’m running into an error I would love help with.

I am trying to create a derived column to add to a Table. I originally tried to add it to the Transactions table, but it didn’t seem to be working. Then I tried to create a copy of that table and add the derived column and it still doesn’t seem to be working. I am not sure exactly what to do here and would love some assistance.

After creating that table I am wanting to add it to my dataset, but that also doesn’t seem to be working? I’m not sure how to check this exactly.
I tried adding the table to the first dataset:

And also creating it as it’s own dataset:

I also have a question on the SQL Queries.
I created this query and I just want to know where do I actually use this? Can I use this to build a visualization off of?:

Lastly, when I create a bling datamodel like this:

Now this model may not be perfect or even work depending on the previous questions, but I did some simpler ones and commited those and I’m not where to view these.

Where do I use the models and how are they helpful?

I think I’m just not seeing the big picture, but I see each individual piece separately and am starting to understand how each piece works.

Thank you so much for your help!

Hi Alex,

Are you not able to explore the datasets?
If that is the case can you confirm if you have followed the following steps:
In general there are 3 steps, in order to explore the datasets after added them to the project: save, commit and deploy.

After you add any column you will have to deploy the data model again.

One more thing: Deployment on development branch and that on the production branch are two separate operations.

I also have a question on the SQL Queries.
I created this query and I just want to know where do I actually use this? Can I use this to build a visualization off of?:

Right now SQL queries are for referencing your data and cross checking your joins. If you want to keep reusing them, you can persist them in the git repository. You cannot visualise them right now. But this feature is in the roadmap.

Yes, I cannot see any changes I am making to the datasets. So if I alter or create a new dataset I cannot see my changes.

Yes, I have done all of these things.

All makes sense! Thank you.

The models are constructed out of your files in your repository. They are converted to a format that Bipp understands internally. Whenever you do an exploration on a dataset, Bipp refers these representations of the data model.
In short, you are already using the data models when you are exploring any dataset.

I hope that answers the query.

Can you try doing the following:

  1. Open the dataset file that you want to explore by clicking on it. In your case, it would MySQL2 or MySQL2_Test.
  2. You should be able to see an Explore button like the one in the image below. Click on it. It should take you to the data viewer area.
    Screenshot 2020-10-29 at 11.10.41 AM
  3. You should be able to see your new columns and new tables there.

Let me know if the steps listed above help you.

That was immensely helpful! I never saw the “Explore” before as it was cut off on my screen.

That helps a ton! Thank you!

We have fixed this issue, and it will be available during our next release. Thank you.

1 Like